HDU Reward(发工资) 2647 (拓扑排序 vector)

Problem Description

Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.

Input

One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.

Output

For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.

Sample Input

2 1
1 2
2 2
1 2
2 1

Sample Output

1777
-1
STL__vector 做法
#include<iostream>
#include<cstring>
#include<queue>
#include<vector>
#include<cstring>
using namespace std;

struct node
{
	int index;
	int sum;
	node(int x,int y){
		index=x;
		sum=y;
	}
};

queue<node>qq;
vector<int>ve[11111];
int count[11111];

void init(int n)
{
	for(int i=1;i<=n;i++){
		ve[i].clear();
		count[i]=0;
	}
}


int main()
{
	int n,m,i,j,v,u,sum,tot;
	while(scanf("%d%d",&n,&m)!=EOF){
		sum=0;
		tot=0;
		init(n);
		for(i=1;i<=m;i++){
			scanf("%d%d",&v,&u);
			count[v]++;
			ve[u].push_back(v);
		}
		for(i=1;i<=n;i++){
			if(count[i]==0) qq.push(node(i,888));
		}
		while(!qq.empty()){
			node temp=qq.front();
			qq.pop();
			sum+=temp.sum;
			tot++;
			for(i=0;i<ve[temp.index].size();i++){
				if(--count[ve[temp.index][i]]==0){
					qq.push(node(ve[temp.index][i],temp.sum+1));
				}
			}
		}
		if(tot==n) printf("%d\n",sum);
		else printf("-1\n");
	}
	return 0;
}


 
   
邻接表
#include <iostream>
#include <cstdio>
#include <queue>
#include <cstring>
#define MM 10005
using namespace std;
int inde[MM];
int add[MM];  //每人要加的。
struct Node
{
    int data;
    Node *next;
    Node():data(0),next(0){}
}*e[MM];
void addEdage(int u,int v)
{
    Node *t =new Node;
    t->data=v;
    t->next=e[u];
    e[u]=t;
}
void init(int n)
{
    memset(e,0,sizeof(e));
    memset(inde,0,sizeof(inde));
    int i;
    for(i=0;i<=n;i++)
        add[i]=888;
}
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        int i,a,b;
        init(n);
        for(i=0;i<m;i++)
        {
            scanf("%d%d",&a,&b);
            addEdage(b,a);       //注意是反向的
            inde[a]++;
        }
        queue<int> q;
        for(i=1;i<=n;i++)
        {
            if(inde[i]==0)
            {
                q.push(i);
            }
        }
        int sum=0;
        int count=0;
        while(!q.empty())
        {
            int t=q.front();
            q.pop();
            count++;
            sum=sum+add[t];
            Node *hh;
            for(hh=e[t];hh;hh=hh->next)
            {
                if(--inde[hh->data]==0)
                {
                    q.push(hh->data);
                    add[hh->data]=add[t]+1;  //注意点
                }
            }
        }
        if(count!=n)
            printf("-1\n");
        else
            printf("%d\n",sum);
    }
    return 0;
}


你可能感兴趣的:(HDU Reward(发工资) 2647 (拓扑排序 vector))