POJ 2533 Longest Ordered Subsequence

题目链接:http://poj.org/problem?id=2533


Longest Ordered Subsequence
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 35605   Accepted: 15621

Description

A numeric sequence of  ai is ordered if  a1 <  a2 < ... <  aN. Let the subsequence of the given numeric sequence ( a1a2, ...,  aN) be any sequence ( ai1ai2, ...,  aiK), where 1 <=  i1 <  i2 < ... <  iK <=  N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

Source

Northeastern Europe 2002, Far-Eastern Subregion

题意:求最长上升子序列长度

题解:DP  这题我WA了两发.....~~~~(>_<)~~~~ 

AC代码:

#include<iostream>
#include<cstring>
#define N 1005
using namespace std;
int dp[N],num[N],n;
int main()
{
    cin.sync_with_stdio(false);
    while(cin>>n){
        int res=1;
        for(int i=0;i<n;i++)dp[i]=1;
        for(int i=0;i<n;i++)cin>>num[i];
        for(int i=1;i<n;i++){
            for(int j=0;j<i;j++){
                 if(num[i]>num[j])dp[i]=max(dp[i],dp[j]+1);
                else if(num[i]==num[j])dp[i]=max(dp[i],dp[j]);
            }
            if(res<dp[i])res=dp[i];
        }
        cout<<res<<endl;
    }
    return 0;
}



你可能感兴趣的:(dp,最长上升子序列)