HDU2054:A == B ?

Problem Description

Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".
 


Input

each test case contains two numbers A and B.
 


Output

for each case, if A is equal to B, you should print "YES", or print "NO".
 


Sample Input

   
   
   
   
1 2 2 2 3 3 4 3
 


Sample Output

   
   
   
   
NO YES YES NO
 



//水题,关键在小数点

 

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
    char a[100000],b[100000];
void change(char s[])
{
    int i,len;
    len  = strlen(s);
    if(strstr(s,"."))
    {
        for(i = len-1; s[i] == '0'; i--)
        {
            s[i] = '\0';
            len--;
        }
    }
    if(s[len-1] == '.')
        s[len-1] = '\0';
}

int main()
{

    while(scanf("%s%s",a,b)!=EOF)
    {
        change(a);
        change(b);
        if(strcmp(a,b))
        printf("NO\n");
        else
        printf("YES\n");
    }

    return 0;
}


 

 

你可能感兴趣的:(C++,ACM,HDU,杭电,解题报告)