Wooden Sticks
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11619 Accepted Submission(s): 4800
Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
Output
The output should contain the minimum setup time in minutes, one per line.
Sample Input
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
Sample Output
Source
Asia 2001, Taejon (South Korea)
题目链接 :http://acm.hdu.edu.cn/showproblem.php?pid=1051
题目大意 :有n根木条,加工第一根需要1时间,如果后一根的长度和重量都大于等于前一根那么机器不用化费额外的时间
现给定n根木条的长度和重量,求出加工这些木条最少需要的时间
题目分析 :采用贪心策略,先对木条的长度或者重量排序,(我是先对长度从小到大排序的,先排重量也一样,从小到大或者从大到小都无所谓但是长度和重量的排序方案一定要统一),长度排完序后再对重量排序,找到一组重量单调增(减)的集合则做出标记,最后求得的集合的数目即为问题的答案。
#include <cstdio>
#include <algorithm>
using namespace std;
int const MAX = 5000 + 5;
struct STICK //定义木条结构体
{
int l;
int w;
}sticks[MAX];
int flag[MAX]; //定义标记数组
bool cmp(STICK a, STICK b)
{
if(a.l != b.l)
return a.l < b.l;
else
return a.w < b.w;
}
int main()
{
int num,min = 0,T;
scanf("%d",&T);
while(T--)
{
scanf("%d",&num);
for(int i = 0; i < num; i++)
{
scanf("%d%d",&sticks[i].l,&sticks[i].w);
flag[i] = 0; //标记数组初始化
}
sort(sticks,sticks + num,cmp); //排序
int cnt = 0;
for(int i = 0; i < num; i++)
{
if(flag[i]) //若已标记(即已属于某一集合)则返回循环体
continue;
min = sticks[i].w;
for(int j = i + 1; j < num; j++)
{
if(min <= sticks[j].w && !flag[j]) //寻找单调增的数的集合并标记
{
min = sticks[j].w;
flag[j] = 1;
}
}
cnt++; //找完一个集合cnt数量加一
}
printf("%d\n",cnt);
}
}