杭电1061--n^n末尾的数

                        Rightmost Digit

Problem Description
Given a positive integer N, you should output the most right digit of N^N.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output
For each test case, you should output the rightmost digit of N^N.

Sample Input
2
3
4

Sample Output
7
6

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

# include <iostream>
# include <cstdio>

using namespace std;
int a[100];

int main(){

    int i,j,k,n,m;


    while(scanf("%d",&m)!=EOF){

    for(i=0;i<m;i++){
        scanf("%d",&n);
        int t = n%10;
        int cnt = 0;
        while(1){//求周期 
            a[cnt++] = t;
            //printf("%d\n",t);
            t =(t*(n%10))%10;

            if(a[0]==t){
                break;
            }   
        }


        n = (n-1)%cnt;
        printf("%d\n",a[n]); 
    }
    }

    return 0;
}

你可能感兴趣的:(杭电)