Harmonious Contest

描述

This is a magic country

Harmonious society

And harmonious people

This is a wonderful contest

Harmonious students

And harmonious problems.

This is the most harmonious problem, and the question is as following:

Given three positive integers A, B and C (0<A,B,C<=100) which denote the length of three edges, please tell me whether they can make up a legal triangle.

输入

The first line is an integer T(T<=100) which indicates the number of test cases.

Each test case consists of three integers A,B and C in a line.

输出

For each test case please output the type of triangleAcute triangleRight triangle or Obtuse triangleif  A,B and C can make up a legal triangle, and output "NO" otherwise. One line per case.

样例输入

4
3 4 4
3 4 5
3 4 6
3 4 7

样例输出

Acute triangle
Right triangle
Obtuse triangle
NO
 
分析:  这个题目就是判断三角形的类型,钝角,直角,锐角。 最大边的平方和其余边的平方和比,如果大,钝角,反之,锐角,相等,直角。
 
code:
#include <iostream>
using namespace std;
int main()
{
   int n,a,b,c;
   cin>>n;
   while(n--)
   {
     cin>>a>>b>>c;
	 if(a+b>c && a+c>b && b+c>a)
	 {
              if(a*a+b*b==c*c || a*a+c*c==b*b || b*b+c*c==a*a)
				  cout<<"Right triangle"<<endl;
			  else if((a*a+b*b)>c*c && (a*a+c*c)>b*b && (b*b+c*c)>a*a)
				  cout<<"Acute triangle"<<endl;
			  else
				  cout<<"Obtuse triangle"<<endl;
	 }
	 else
		 cout<<"NO"<<endl;
   }
   return 0;
}

 
 

你可能感兴趣的:(Harmonious Contest)