Tunnel Warfare
Time Limit: 1000MS Memory Limit: 131072K
Total Submissions: 7576 Accepted: 3127
Description
During the War of Resistance Against Japan, tunnel warfare was carried out extensively in the vast areas of north China Plain. Generally speaking, villages connected by tunnels lay in a line. Except the two at the ends, every village was directly connected with two neighboring ones.
Frequently the invaders launched attack on some of the villages and destroyed the parts of tunnels in them. The Eighth Route Army commanders requested the latest connection state of the tunnels and villages. If some villages are severely isolated, restoration of connection must be done immediately!
Input
The first line of the input contains two positive integers n and m (n, m ≤ 50,000) indicating the number of villages and events. Each of the next m lines describes an event.
There are three different events described in different format shown below:
D x: The x-th village was destroyed.
Q x: The Army commands requested the number of villages that x-th village was directly or indirectly connected with including itself.
R: The village destroyed last was rebuilt.
Output
Output the answer to each of the Army commanders’ request in order on a separate line.
Sample Input
7 9
D 3
D 6
D 5
Q 4
Q 5
R
Q 4
R
Q 4
Sample Output
1
0
2
4
Hint
An illustration of the sample input:
OOOOOOO
D 3 OOXOOOO
D 6 OOXOOXO
D 5 OOXOXXO
R OOXOOXO
R OOXOOOO
Source
POJ Monthly–2006.07.30, updog
题目链接:http://poj.org/problem?id=2892
题意:有n个村庄进行m次操作,有三种操作
D x:表示摧毁一个村庄
Q x:表示查询一个村庄左右连续的存在的村庄个数,若该村庄不存在为0
R:表示修复上一个被摧毁的村庄
思路:
树状数组维护类似前缀和的东西;二分判定是否连续有村庄
O(mlogn^2)
判定条件:if(_get(rx)-_get(mid-1)==rx-mid+1)右边已合法!
或if(_get(x)-_get(mid-1)==x-mid+1)
while(rx>=lx)
{
mid=(rx+lx)>>1;
if(_get(rx)-_get(mid-1)==rx-mid+1)
{
ans=mid;
rx=mid-1;
}
else lx=mid+1;
}
int t1=ans;
*二分姿势:while(rx>=lx) if(C(mid)) ans=mid;
代码:
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<stack>
using namespace std;
int n,m;
int C[50005];
char s[3];
int aa;
stack<int> pre;
void add(int x,int y)
{
while(x<=n)
{
C[x]+=y;
x+=x&(-x);
}
}
int _get(int x)
{
int ret=0;
while(x>0)
{
ret+=C[x];
x-=x&(-x);
}
return ret;
}
int solve(int x)
{
if(_get(x)-_get(x-1)==0) return 0;
int rx=x;
int lx=1;
int mid;
int ans;
while(rx>=lx)
{
mid=(rx+lx)>>1;
if(_get(rx)-_get(mid-1)==rx-mid+1)
{
ans=mid;
rx=mid-1;
}
else lx=mid+1;
}
int t1=ans;
rx=n;
lx=x;
//int cnt=0;
while(rx>=lx)
{
mid=(rx+lx)>>1;
if(_get(mid)-_get(lx-1)==mid-lx+1)
{
lx=mid+1;
ans=mid;
}
else rx=mid-1;
}
return ans-t1+1;
}
int main()
{
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++)
add(i,1);
for(int i=1;i<=m;i++)
{
scanf("%s",s);
if(s[0]!='R') scanf("%d",&aa);
if(s[0]=='D')
{
add(aa,-1);
pre.push(aa);
}
else if(s[0]=='Q')
{
printf("%d\n",solve(aa));
}
else if(s[0]=='R')
{
int tmp=pre.top();
pre.pop();
add(tmp,1);
}
}
}