杭电1028

                Ignatius and the Princess III

Problem Description
“Well, it seems the first problem is too easy. I will let you know how foolish you are later.” feng5166 says.

“The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+…+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that “4 = 3 + 1” and “4 = 1 + 3” is the same in this problem. Now, you do it!”

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

Sample Input
4
10
20

Sample Output
5
42
627

题意:就是计算例如:谁加谁等于4
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
输出5

原理:

第一项:1+x+x^2+x^3…………..
这每一项的意思:
0个1(x^0),1个1(x^1),两个1组成2(x^2),三个1组成3…….n个1组成n(x^n)
第二项:1+x^2+x^4…………..
0个2(x^0),1个2(x^2),两个2(x^4)…………………….

代码:

# include <iostream>

using namespace std;

int main(){

    int n,i,j,k;
    int c1[130],c2[130];

    while(cin>>n){

        //对第一项进行赋值 
        for(i=0;i<=n;i++){
            c1[i] = 1;
            c2[i] = 0;
        }

        for(i=2;i<=n;i++){//代表第i项 

            for(j=0;j<=n;j++){//代表i-1项,其中,满足项的系数j<=n的进行循环,这里不一定是j-1的每一项 
                for(k=0;k+j<=n;k+=i){//i项符合条件的
                    c2[j+k]+= c1[j];//i-1项的每一个符合条件的与i项相乘 
                } 
            }

            for(k=0;k<=n;k++){
                c1[k] = c2[k];//把i与i-1项的乘积从临时保存到c2到保存到c1中,等待i+1项与c1的成绩 
                c2[k] = 0;
            }    
        } 
        cout<<c1[n]<<endl; 
    }
    return 0;
}

你可能感兴趣的:(杭电,母函数)