TIANKENG’s restaurant
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 1606 Accepted Submission(s): 577
Problem Description
TIANKENG manages a restaurant after graduating from ZCMU, and tens of thousands of customers come to have meal because of its delicious dishes. Today n groups of customers come to enjoy their meal, and there are Xi persons in the ith group in sum. Assuming that each customer can own only one chair. Now we know the arriving time STi and departure time EDi of each group. Could you help TIANKENG calculate the minimum chairs he needs to prepare so that every customer can take a seat when arriving the restaurant?
Input
The first line contains a positive integer T(T<=100), standing for T test cases in all.
Each cases has a positive integer n(1<=n<=10000), which means n groups of customer. Then following n lines, each line there is a positive integer Xi(1<=Xi<=100), referring to the sum of the number of the ith group people, and the arriving time STi and departure time Edi(the time format is hh:mm, 0<=hh<24, 0<=mm<60), Given that the arriving time must be earlier than the departure time.
Pay attention that when a group of people arrive at the restaurant as soon as a group of people leaves from the restaurant, then the arriving group can be arranged to take their seats if the seats are enough.
Output
For each test case, output the minimum number of chair that TIANKENG needs to prepare.
Sample Input
2
2
6 08:00 09:00
5 08:59 09:59
2
6 08:00 09:00
5 09:00 10:00
Sample Output
11
6
C语言程序代码
/*
比较简单的贪心题
题意::
餐馆 各个时间段都有客人用餐问餐馆要准备的凳子数。
解题思路::
将小时换算成分钟,将用餐时段所用的凳子数相加,取最大数,
(这种方法简单,易懂,开始写的超时)
*/
#include<stdio.h>
#include<string.h>
#include<math.h>
int max(int x,int y)
{
return x>y?x:y;
}
int a[1500];
int main(){
int t,n,m,i,j,k,l,l1;
scanf("%d",&t);
while(t--)
{
memset(a,0,sizeof(a));
scanf("%d",&n);
int h1,h2,m1,m2;
for(i=0;i<n;i++)
{
scanf("%d %d:%d %d:%d",&m,&h1,&m1,&h2,&m2);
l=h1*60+m1,l1=h2*60+m2;
for(j=l;j<l1;j++)
a[j]+=m;
}
k=-1;
for(i=0;i<1500;i++)
k=max(k,a[i]);
printf("%d\n",k);
}
return 0;
}