树形dp-hdu1520

D - Anniversary party
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit  Status

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings. 
 

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0
 

Output

Output should contain the maximal sum of guests' ratings. 
 

Sample Input

      
      
      
      
7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0
 

Sample Output

5

题意:公司聚会,每个人有一个快乐值,只有员工a的直接上级不在场是a才能得到他的快乐值, 问最大快乐值和是多少

树形dp,dp[i][0]=k,表示在i不在场是最大快乐值为k,dp[i][1]=k,i不在场最大快乐值为k,从树底向上更新dp值

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <vector>
using namespace std;
const int maxn=6050;
int dp[maxn][2];
int n;
int val[maxn];
vector<int>edge[maxn];
int max(int a,int b)
{
    if(a>b)
        return a;
    return b;
}
void init()
{
    for(int i=0;i<=n;i++)
        edge[i].clear();
}
void dfs(int u,int pre)
{
    if(edge[u].size()==1)
        {
            dp[u][0]=0,dp[u][1]=val[u];
            return ;
        }
    for(int i=0;i<edge[u].size();i++)
    {
        int v=edge[u][i];
        if(v==pre)continue;
        dfs(v,u);
        dp[u][0]+=max(dp[v][0],dp[v][1]);
        dp[u][1]+=dp[v][0];
    }
}
int main()
{
    int u,v;
    while(scanf("%d",&n)!=-1)
    {
        init();
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&val[i]);
           dp[i][0]=0;
           dp[i][1]=val[i];
        }
        while(1)
        {
            scanf("%d%d",&u,&v);
            if(u==0&&v==0)
                break;
            edge[u].push_back(v);
            edge[v].push_back(u);
        }
        int root=1;
        while(edge[root++].size()==1);
        dfs(root,0);
        printf("%d\n",max(dp[root][0],dp[root][1]));
    }
    return 0;
}


你可能感兴趣的:(树形dp-hdu1520)