sicily 1239. Smallest Differencev

1239. Smallest Differencev

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Given a number of distinct decimal digits, you can form one integer by choosing a non-empty subset of these digits and writing them in some order. The remaining digits can be written down in some order to form a second integer. Unless the resulting integer is 0, the integer may not start with the digit 0.

For example, if you are given the digits 0, 1, 2, 4, 6 and 7, you can write the pair of integers 10 and 2467. Of course, there are many ways to form such pairs of integers: 210 and 764, 204 and 176, etc. The absolute value of the difference between the integers in the last pair is 28, and it turns out that no other pair formed by the rules above can achieve a smaller difference.

Input

The first line of input contains the number of cases to follow. For each case, there is one line of input containing at least two but no more than 10 decimal digits. (The decimal digits are 0, 1, ..., 9.) No digit appears more than once in one line of the input. The digits will appear in increasing order, separated by exactly one blank space.

Output

For each test case, write on a single line the smallest absolute difference of two integers that can be written from the given digits as described by the rules above.

Sample Input

1
0 1 2 4 6 7

Sample Output

28


题目分析

升序给出0到9间的若干个数,不重复
用若干位组成十进制数,剩余位也组成十进制数字,求使两个数的差的绝对值最小
注意0的特殊性,不能存在前缀零
剪枝有:只输入0时打印0,只输入两个数时,直接相减输出
其他情况用next_permutation直接暴力枚举
做差前确保str[0]和str[str.lenght()/2]不为'0'


#include <iostream>
#include <algorithm>
#include <cmath>

int main()
{
  int test;
  std::cin >> test;
  std::string line;
  getline(std::cin, line);
  while (test--) {
    getline(std::cin, line);
    if (line == "0") {
      std::cout << "0" << std::endl;
      continue;
    }
    if (line.length() == 3) {
      std::cout << line[2] - line[0] << std::endl;
      continue;
    }
    std::string str = "";
    for (int i = 0; i < line.length(); i += 2)
      str = str + line[i];
//std::cout << str << std::endl;
    int min = 44444;
    int astart = 0;
    int bstart = str.length()/2;
    do {
      if (str[astart] == '0' || str[bstart] == '0')
        continue;
      int a = 0, weight = 1;
      for (int i = bstart-1; i >= 0; --i) {
        a += (str[i] - '0') * weight;
        weight *= 10;
      }
      int b = 0;
      weight = 1;
      for (int i = str.length()-1; i >= bstart; --i) {
        b += (str[i] - '0') * weight;
        weight *= 10;
      }
      min = min < fabs(a-b) ? min : fabs(a-b);
//std::cout << a << "  " << b << "   " << min << std::endl;
    }  while (std::next_permutation(str.begin(), str.end()));
    std::cout << min << std::endl;
  }
}

你可能感兴趣的:(sicily 1239. Smallest Differencev)