ACM technicians faced a very interesting problem recently. Given a set of BTSes to visit, they needed to find the shortest path to visit all of the given points and return back to the central company building. Programmers have spent several months studying this problem but with no results. They were unable to find the solution fast enough. After a long time, one of the programmers found this problem in a conference article. Unfortunately, he found that the problem is so called "Travelling Salesman Problem" and it is very hard to solve. If we have N BTSes to be visited, we can visit them in any order, giving us N! possibilities to examine. The function expressing that number is called factorial and can be computed as a product 1.2.3.4....N. The number is very high even for a relatively small N.
The programmers understood they had no chance to solve the problem. But because they have already received the research grant from the government, they needed to continue with their studies and produce at least some results. So they started to study behaviour of the factorial function.
For example, they defined the function Z. For any positive integer N, Z(N) is the number of zeros at the end of the decimal form of number N!. They noticed that this function never decreases. If we have two numbers N1<N2, then Z(N1) <= Z(N2). It is because we can never "lose" any trailing zero by multiplying by any positive number. We can only get new and new zeros. The function Z is very interesting, so we need a computer program that can determine its value efficiently.
Input
There is a single positive integer T on the first line of input. It stands for the number of numbers to follow. Then there is T lines, each containing exactly one positive integer number N, 1 <= N <= 1000000000.
Output
For every number N, output a single line containing the single non-negative integer Z(N).
Sample Input
6
3
60
100
1024
23456
8735373
Sample Output
0
14
24
253
5861
2183837
Source: Central Europe 2000
***********************************************************************************************************************
#include<iostream>
using namespace std;
int main()
{
int count, zeros;
long long num;
cin>>count;
while(count--)
{
cin>>num;
zeros = 0;
while(num / 5)
{
zeros += num / 5;
num /= 5;
}
cout<<zeros<<endl;
}
return 0;
}
CSDN的:要看1到n连续相乘尾数有多少个0,就看这n个数中,有多少个是5的倍数。因为1-n个数中肯定可以提供足够的偶数,所以,只要有5的倍数就一定能够把它乘成10的倍数,就是说n以下有多少个数是5的倍数,那么它的阶乘就有多少个0。
比如60/5的意思是,从1 2 3 ....60 中有12个数是5的倍数,这些数相乘会出来12个0。。因为2比较多~每个数可以保证与一个2相乘,得到一个X0~
下面这个循环是重点,为什么要拿除以5后的数再除以5?因为比如是25的话,相乘的话会得到2个0,比如25*4=100。这样的话就要确定60里面有多少个25的倍数~~~~用得到的12去/5。。。如果数比较大的话也是这么理解滴~~5^3...5^4and so on~~~~