POJ 3301 Texas Trip(三分)

Description

After a day trip with his friend Dick, Harry noticed a strange pattern of tiny holes in the door of his SUV. The local American Tire store sells fiberglass patching material only in square sheets. What is the smallest patch that Harry needs to fix his door?

Assume that the holes are points on the integer lattice in the plane. Your job is to find the area of the smallest square that will cover all the holes.

Input

The first line of input contains a single integer T expressed in decimal with no leading zeroes, denoting the number of test cases to follow. The subsequent lines of input describe the test cases.

Each test case begins with a single line, containing a single integer n expressed in decimal with no leading zeroes, the number of points to follow; each of the following n lines contains two integers x and y, both expressed in decimal with no leading zeroes, giving the coordinates of one of your points.

You are guaranteed that T ≤ 30 and that no data set contains more than 30 points. All points in each data set will be no more than 500 units away from (0,0).

Output

Print, on a single line with two decimal places of precision, the area of the smallest square containing all of your points.

Sample Input

2
4
-1 -1
1 -1
1 1
-1 1
4
10 1
10 -1
-10 1
-10 -1

Sample Output

4.00
242.00
给定n个点的坐标求一个最小的正方形使n个点都在正方形内
先假定边长最小且个边都平行于坐标轴的正方形,然后三分旋转的角度 
  
  
  
  
这里要知道坐标旋转公式:
如果为旋转前的坐标,为旋转后的坐标,那么有:
 
代码如下:
#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;

const double eps = 1e-12;

const double INF = 1e6;

const double PI = acos(-1.0);

double p[35][2];

int n;

double cir(double x){//旋转x角度后对应点的位置
    double minx,miny,maxx,maxy;
    double tmpx,tmpy;
    minx=miny=INF;
    maxx=maxy=-INF;
    for(int i=0;i<n;i++){
        tmpx=p[i][0]*cos(x)-p[i][1]*sin(x);
        tmpy=p[i][1]*cos(x)+p[i][0]*sin(x);
        minx=min(tmpx,minx);
        miny=min(tmpy,miny);
        maxx=max(tmpx,maxx);
        maxy=max(tmpy,maxy);
    }
    return max(maxx-minx,maxy-miny);
}

double ternary_search(double l,double r){//三分旋转的角度
    double ll,rr;
    while(r-l>eps){
        ll=(l*2+r)/3;
        rr=(l+r*2)/3;
        if(cir(ll)>cir(rr))
            l=ll;
        else
            r=rr;
    }
    return l;
}

int main()
{
    int cas;
    cin>>cas;
    while(cas--){
        cin>>n;
        for(int i=0;i<n;i++)
            cin>>p[i][0]>>p[i][1];
        double l=0,r=PI/2;
        double tmp=ternary_search(l,r);
        printf("%.2lf\n",cir(tmp)*cir(tmp));
    }
    return 0;
}


你可能感兴趣的:(POJ 3301 Texas Trip(三分))