找新朋友 HDU杭电1286 【欧拉函数】

http://acm.hdu.edu.cn/showproblem.php?pid=1286

Problem Description
新年快到了,“猪头帮协会”准备搞一个聚会,已经知道现有会员N人,把会员从1到N编号,其中会长的号码是N号,凡是和会长是老朋友的,那么该会员的号码肯定和N有大于1的公约数,否则都是新朋友,现在会长想知道究竟有几个新朋友?请你编程序帮会长计算出来。
 

Input
第一行是测试数据的组数CN(Case number,1<CN<10000),接着有CN行正整数N(1<n<32768),表示会员人数。
 

Output
对于每一个N,输出一行新朋友的人数,这样共有CN行输出。
 

Sample Input
   
   
   
   
2 25608 24027
 

Sample Output
   
   
   
   
7680 16016
 



#include <stdio.h>
#include <math.h>
int Euler(int n)
{
    int ans=n;
    for(int i=2;i*i<=n;i++)
		if(n%i==0)
		{
			ans=ans/i*(i-1);//先进行除法防止溢出(ans=ans*(1-1/p(i)))
			while(n%i==0)
				n/=i;
		}
    if(n>1)
    	ans=ans/n*(n-1);
    return ans;
}

int main()
{
	int T;
	int N;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&N);
		printf("%d\n",Euler(N));
	}
	return 0;
}


你可能感兴趣的:(找新朋友 HDU杭电1286 【欧拉函数】)