poj1734(floyd算法)

Description

There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attractions, sightseeing the town. To earn as much as possible from this attraction, the agency has accepted a shrewd decision: it is necessary to find the shortest route which begins and ends at the same place. Your task is to write a program which finds such a route. 

In the town there are N crossing points numbered from 1 to N and M two-way roads numbered from 1 to M. Two crossing points can be connected by multiple roads, but no road connects a crossing point with itself. Each sightseeing route is a sequence of road numbers y_1, ..., y_k, k>2. The road y_i (1<=i<=k-1) connects crossing points x_i and x_{i+1}, the road y_k connects crossing points x_k and x_1. All the numbers x_1,...,x_k should be different.The length of the sightseeing route is the sum of the lengths of all roads on the sightseeing route, i.e. L(y_1)+L(y_2)+...+L(y_k) where L(y_i) is the length of the road y_i (1<=i<=k). Your program has to find such a sightseeing route, the length of which is minimal, or to specify that it is not possible,because there is no sightseeing route in the town.

Input

The first line of input contains two positive integers: the number of crossing points N<=100 and the number of roads M<=10000. Each of the next M lines describes one road. It contains 3 positive integers: the number of its first crossing point, the number of the second one, and the length of the road (a positive integer less than 500).

Output

There is only one line in output. It contains either a string 'No solution.' in case there isn't any sightseeing route, or it contains the numbers of all crossing points on the shortest sightseeing route in the order how to pass them (i.e. the numbers x_1 to x_k from our definition of a sightseeing route), separated by single spaces. If there are multiple sightseeing routes of the minimal length, you can output any one of them.

Sample Input

5 7
1 4 1
1 3 300
3 1 10
1 2 16
2 3 100
2 5 15
5 3 20

Sample Output

1 3 5 2


又是floyd算法,不过这题要求记录路径,刚开始光看代码可能有点迷!茫!

不过,这题主要是在平常成环基础上加了个记录路径的数组pre[i][j],来表示j的上一个是谁,于是就方便记录了所有的遍历过的点。

所以,再看看代码吧~~

#include <iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[110][110],d[110][110],pre[110][110],oo[110];
const int maxn=100000000;
void init(int n)
{
    memset(oo,0,sizeof(oo));
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
        a[i][j]=d[i][j]=maxn,pre[i][j]=i;
}

int main()
{
    int m,n;
    while(~scanf("%d%d",&n,&m))
    {
        init(n);
        for(int i=0;i<m;i++)
        {
            int a1,a2,ww;
            scanf("%d%d%d",&a1,&a2,&ww);
           if(a[a1][a2]>ww)
           a[a1][a2]=a[a2][a1]=d[a1][a2]=d[a2][a1]=ww;
        }
        int min0=maxn,num=0;
        for(int k=1;k<=n;k++)
        {
            for(int i=1;i<k;i++)
                for(int j=i+1;j<k;j++)
                    if(min0>d[i][j]+a[i][k]+a[k][j])
                    {
                        min0=d[i][j]+a[i][k]+a[k][j];
                        num=0;
                        int p=j;
                        while(p!=i)
                        {
                        oo[num++]=p;
                        p=pre[i][p];
                        }
                        oo[num++]=i;
                        oo[num++]=k;
                    }
            for(int i=1;i<=n;i++)
                for(int j=1;j<=n;j++)
                    if(d[i][k]+d[k][j]<d[i][j])
                    {
                        d[i][j]=d[i][k]+d[k][j];
                        pre[i][j]=pre[k][j];
                    }
        }
        if(min0==maxn)
        printf("No solution.\n");
        else
        {
            cout<<oo[0];
            for(int i=1;i<num;i++)
            cout<<' '<<oo[i];
            cout<<endl;
        }
    }
    return 0;
}

你可能感兴趣的:(ACM,图,大一)