Rightmost Digit
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 24 Accepted Submission(s) : 11
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
Given a positive integer N, you should output the most right digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the rightmost digit of N^N.
Sample Input
Sample Output
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
Author
Ignatius.L
一开始忽略了数很大,上来就编了,给的数据一测试对了,超兴奋的交上去了,结果却是超时。
当时的代码是:
#include <iostream>
#include <cstdio>
using namespace std;
int main()
{
long long int i,j,m,n,s;
cin>>n;
for(j=0;j<n;j++)
{
cin>>s;
m=1;
for(i=0;i<s;i++)
{
m=(m*(s%10))%10;
}
cout<<m<<endl;
}
return 0;
}
一定要想方法解决超时问题,最终自己还是没解决,求助大神后才顿悟。
正确代码:
#include <iostream>
#include <cstdio>
using namespace std;
int main()
{
int T,n,a,t;
cin>>T;
while(T--)
{
cin>>n;
a=n;
t=1;
n%=10;
while(a>=1)
{
if(a&1)
t=(t*n)%10;
n=(n*n)%10;
a/=2;
}
cout<<t<<endl;
}
return 0;
}