[poj 3140] Contestants Division  树形DP

Contestants Division
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9160 Accepted: 2630

Description

In the new ACM-ICPC Regional Contest, a special monitoring and submitting system will be set up, and students will be able to compete at their own universities. However there’s one problem. Due to the high cost of the new judging system, the organizing committee can only afford to set the system up such that there will be only one way to transfer information from one university to another without passing the same university twice. The contestants will be divided into two connected regions, and the difference between the total numbers of students from two regions should be minimized. Can you help the juries to find the minimum difference?

Input

There are multiple test cases in the input file. Each test case starts with two integers N and M, (1 ≤ N ≤ 100000, 1 ≤ M ≤ 1000000), the number of universities and the number of direct communication line set up by the committee, respectively. Universities are numbered from 1 to N. The next line has N integers, the Kth integer is equal to the number of students in university numbered K. The number of students in any university does not exceed 100000000. Each of the following M lines has two integers s, t, and describes a communication line connecting university s and university t. All communication lines of this new system are bidirectional.

N = 0, M = 0 indicates the end of input and should not be processed by your program.

Output

For every test case, output one integer, the minimum absolute difference of students between two regions in the format as indicated in the sample output.

Sample Input

7 6
1 1 1 1 1 1 1
1 2
2 7
3 7
4 6
6 2
5 7
0 0

Sample Output

Case 1: 1

Source
Shanghai 2006

题目链接
http://poj.org/problem?id=3140

题意
给出n个点,m条无向边,m实际上就是n-1,组成的一棵树,拆掉一条边后,树会变为两个,问两个树的差最小是多少?

思路
树形DP(连dp数组都没好吧。。。)
dfs的过程中维护一个min值(即枚举删的边);

代码

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<vector>
using namespace std;
int n,m;
long long sum;
long long ans;
vector<int> lin[100010];
long long a[100010];
long long dfs(int x,int pre)
{
    long long ret=0;
    for(int i=0;i<lin[x].size();i++)
    {
        int now=lin[x][i];
        if(now==pre) continue;
        long long tmp=dfs(now,x);
        ret+=tmp;   
        long long tt=sum-tmp*2;
        if(tt<0)  tt=-tt;
        ans=min(ans,tt);

    }
    return ret+a[x];
}
int main()
{
    int T=0;
    int aa,bb;
    while(scanf("%d%d",&n,&m))
    {   
        if(n==0) return 0;
        sum=0;
        ans=9999999999999999;

        for(int i=1;i<=n;i++)
        {
            scanf("%lld",&a[i]);
            lin[i].clear();
            sum+=a[i];
        }
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&aa,&bb);
            lin[aa].push_back(bb);
            lin[bb].push_back(aa);
        }
        dfs(1,0);
        if(n==1) ans=a[1];
        printf("Case %d: %lld\n", ++T, ans) ;
    }

}

你可能感兴趣的:(poj,ACM-ICPC)