poj 2352 Stars(树状数组)

http://poj.org/problem?id=2352

Stars

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 
poj 2352 Stars(树状数组)_第1张图片
For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

大意是N个星星,规定每个星星的等级为在它左下方星星的数量(包括某个坐标相等),N范围是15000,输入按y坐标的升序给出,如果两个星星y坐标相等,按x坐标升序给出。
用树状数组,不用管y坐标(因为已经是升序,后边的星星不影响前边星星的等级),用tree(n)来统计x坐标为n以前的星星个数,但是千万注意树状数组需要数组以1为首项,由于坐标有0,所以每次需要给x坐标+1。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <limits>
#include <queue>
#include <stack>
#include <vector>
#include <map>

using namespace std;
typedef long long LL;

#define N 35110
#define INF 0x3f3f3f3f
#define PI acos (-1.0)
#define EPS 1e-8
#define met(a, b) memset (a, b, sizeof (a))

int tree[N*100], sum[N*100];

int lowbit (int t)
{
    return t&(-t);
}

void update (int pos, int num)
{
    while (pos <= N)
    {
        tree[pos] += num;
        pos += lowbit (pos);
    }
}

int Plus (int pos)
{
    int ans = 0;
    while (pos)
    {
        ans += tree[pos];
        pos -= lowbit (pos);
    }
    return ans;
}

int main ()
{
    int n;

    while (scanf ("%d", &n) != EOF)
    {
        int x, y;
        met (tree, 0);
        met (sum, 0);

        for (int i=1; i<=n; i++)
        {
            scanf ("%d %d", &x, &y);
            update (x+1, 1);
            sum[Plus (x+1)-1]++;
        }

        for (int i=0; i<n; i++)
            printf ("%d\n", sum[i]);
    }
    return 0;
}


你可能感兴趣的:(poj 2352 Stars(树状数组))