HDOJ 5671 Matrix

Matrix

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 780    Accepted Submission(s): 330


Problem Description
There is a matrix M that has n rows and m columns (1n1000,1m1000) .Then we perform q(1q100,000) operations:

1 x y: Swap row x and row y (1x,yn) ;

2 x y: Swap column x and column y (1x,ym) ;

3 x y: Add y to all elements in row x (1xn,1y10,000) ;

4 x y: Add y to all elements in column x (1xm,1y10,000) ;
 

Input
There are multiple test cases. The first line of input contains an integer T(1T20) indicating the number of test cases. For each test case:

The first line contains three integers n , m and q .
The following n lines describe the matrix M. (1Mi,j10,000) for all (1in,1jm) .
The following q lines contains three integers a(1a4) , x and y .
 

Output
For each test case, output the matrix M after all q operations.
 

Sample Input
   
   
   
   
2 3 4 2 1 2 3 4 2 3 4 5 3 4 5 6 1 1 2 3 1 10 2 2 2 1 10 10 1 1 1 2 2 1 2
 

Sample Output
   
   
   
   
12 13 14 15 1 2 3 4 3 4 5 6 1 10 10 1
Hint
Recommand to use scanf and printf
 


中文题面:BC Round #81 (div.2)1002  


代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int map[1010][1010];
int row[1010],col[1010];
int hx[1010],hy[1010]; 
int main()
{
	int t,n,m,q,i,j,a,x,y;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d%d",&n,&m,&q);
		for(i=1;i<=n;++i)
		{
			for(j=1;j<=m;++j)
			{
				scanf("%d",&map[i][j]);
				row[i]=i; 
				hx[i]=0;
			}
		}
		for(j=1;j<=m;++j)
		{
			col[j]=j;
			hy[j]=0;
		}
		while(q--)
		{
			scanf("%d%d%d",&a,&x,&y);
			if(a==1)
				swap(row[x],row[y]);
			else if(a==2)
				swap(col[x],col[y]);
			else if(a==3)
				hx[row[x]]+=y;
			else 
				hy[col[x]]+=y; 
				
		}
		for(i=1;i<=n;++i)
		{
			for(j=1;j<=m;++j)
			{
				if(j==m)
					printf("%d\n",map[row[i]][col[j]]+hx[row[i]]+hy[col[j]]);
				else
					printf("%d ",map[row[i]][col[j]]+hx[row[i]]+hy[col[j]]);
			}
		} 
	} 
	return 0;
} 




你可能感兴趣的:(HDOJ 5671 Matrix)