POJ 1256 Anagram

POJ 1256  Anagram
Time Limit: 1000 MS      Memory Limit: 10000 KB      64bit IO Format: %I64d & %I64u

Description

      You are to write a program that has to generate all possible words from a given set of letters. 
Example: Given the word "abc", your program should - by exploring all different combination of the three

 letters - output the words "abc", "acb", "bac", "bca", "cab" and "cba". 

In the word taken from the input file, some letters may appear more than once. For a given word,

 your program should not produce the same word

 more than once, and the words should be output in alphabetically ascending order. 


Input

          The input consists of several words. The first line contains a number giving the number of

words to follow.Each following line contains one word.

 A word consists of uppercase or lowercase letters from A to Z. Uppercase and lowercase letters 

are to be considered different.The length of each word is less than 13.


Output

For each word in the input, the output should contain all different words that can be 

generated with the letters of the given word.

 The words generated from the same input word should be output in alphabetically ascending order.

 An upper case letter goes before the corresponding lower case letter.


Sample Input

3

aAb

abc

acba


Sample Output

Aab

Aba

aAb

abA

bAa

baA

abc

acb

bac

bca

cab

cba

aabc

aacb

abac

abca

acab

acba

baac

baca

bcaa

caab

caba

cbaa


Hint

An upper case letter goes before the corresponding lower case letter. 
So the right order of letters is 'A'<'a'<'B'<'b'<...<'Z'<'z'.


 本题主要是运用STL中的下一个排序函数(next_permutation())解答

由于需要对序列的大小进行重新的定义,所以用到了自己定义新的cmp()

函数进行调用对序列的大小顺序进行重新排。


附上代码:

#include <iostream>
#include <algorithm>
#include <cstring>
#include <string>
#include <cstdio>
using namespace std;

int cmp(char a,char b)
{
	if(tolower(a) != tolower(b))
	return tolower(a) < tolower(b);
	else
	return a < b;
}

int main()
{
	int n;
	cin >> n;
	while(n--)
	{
		char s[20];
		cin >> s;
		sort(s,s+strlen(s),cmp);
		do
		{
			cout << s << endl;
		}while(next_permutation(s,s+strlen(s),cmp));
	}
	return 0;
}


你可能感兴趣的:(排序,函数,poj)