Kaitou Kid - The Phantom Thief (1) 第三次周赛

Kaitou Kid - The Phantom Thief (1)

Time Limit : 3000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 21   Accepted Submission(s) : 10
Problem Description
Do you know Kaitou Kid? In the legend, Kaitou Kid is a master of disguise, and can take on the voice and form of anyone. He is not an evil person, but he is on the wrong side of the law. He's the very elusive phantom thief who never miss his prey although he always uses word puzzles to announce his targets before action.

Kaitou Kid - The Phantom Thief (1) 第三次周赛_第1张图片

You are the leader of a museum. Recently, you get several priceless jewels and plan to hold an exhibition. But at the moment, you receive Kid's word puzzle... Fortunately, It seems Kid doesn’t want to trouble you, and his puzzle is very easy. Just a few minutes, You have found the way to solve the puzzle:

(1) change 1 to 'A', 2 TO 'B',..,26 TO 'Z'
(2) change '#' to a blank
(3) ignore the '-' symbol, it just used to separate the numbers in the puzzle
 

Input
The first line of the input contains an integer C which means the number of test cases. Then C lines follow. Each line is a sentence of Kid’s word puzzle which is consisted of '0' ~ '9' , '-' and '#'. The length of each sentence is no longer than 10000.
 

Output
For each case, output the translated text.
 

Sample Input
   
   
   
   
4 9#23-9-12-12#19-20-5-1-12#1-20#12-5-1-19-20#15-14-5#10-5-23-5-12 1-14-4#12-5-1-22-5#20-8-5#13-21-19-5-21-13#9-14#20#13-9-14-21-20-5-19 1-6-20-5-18#20-8-5#15-16-5-14-9-14-7#15-6#20-8-5#5-24-8-9-2-9-20-9-15-14 7-15-15-4#12-21-3-11
 

Sample Output
   
   
   
   
I WILL STEAL AT LEAST ONE JEWEL AND LEAVE THE MUSEUM IN T MINUTES AFTER THE OPENING OF THE EXHIBITION GOOD LUCK
 


用string  就是不过
#include<iostream>
#include<cstdio>
#include<string>
using namespace std;
char a[10001];
int main()
{
	int n;
	cin>>n;
	getchar();
	while(n--)
	{

		//string a;
		//string::size_type i,j;
		//getline(cin,a);
		int i,j;
		
		cin.getline(a,10001);
		for(i=0;i<strlen(a);++i)
		{
			
			j=i;
			if(a[i]-'0'>=0&&a[i]-'0'<=9)
			{
				if(a[i+1]-'0'>=0&&a[i+1]-'0'<=9&&i+1!=strlen(a))
				
					{
						cout<<char(((a[i]-'0')*10+a[i+1]-'0')+'@');
						++j;
					}
				else
					{
						
							cout<<char(a[i]-'0'+'@');
					}
			}
			if(a[i]=='#')
				cout<<' ';
			i=j;
			if(a[i]=='-')
				continue;
		}
		cout<<endl;
	}
}

奇怪了,一开始string不过  现在过了
#include<iostream>
#include<cstdio>
#include<string>
using namespace std;
//char a[10001];
int main()
{
	int n;
	cin>>n;
	getchar();
	while(n--)
	{

		string a;
		string::size_type i,j;
		getline(cin,a);
		//int i,j;
		
		//cin.getline(a,10001);
		for(i=0;i<a.size();++i)
		{
			
			j=i;
			if(a[i]-'0'>=0&&a[i]-'0'<=9)
			{
				if(a[i+1]-'0'>=0&&a[i+1]-'0'<=9&&i+1!=a.size())
				
					{
						cout<<char(((a[i]-'0')*10+a[i+1]-'0')+'@');
						++j;
					}
				else
					{
						
							cout<<char(a[i]-'0'+'@');
					}
			}
			if(a[i]=='#')
				cout<<' ';
			i=j;
			if(a[i]=='-')
				continue;
		}
		cout<<endl;
	}
}


你可能感兴趣的:(Kaitou Kid - The Phantom Thief (1) 第三次周赛)