POJ 2481 Cows

Description


Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good.

Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E].

But some cows are strong and some are weak. Given two cows: cow i and cow j, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cow i is stronger than cow j.

For each cow, how many cows are stronger than her? Farmer John needs your help!

Input


The input contains multiple test cases.
For each test case, the first line is an integer N (1 <= N <= 10 5), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 10 5) specifying the start end location respectively of a range preferred by some cow. Locations are given as distance from the start of the ridge.

The end of the input contains a single 0.

Output


For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cow i.

Sample Input

3
1 2
0 3
3 4
0

Sample Output

1 0 0

Hint

Huge input and output,scanf and printf is recommended.

题意:给出若干区间,判断每个区间被其他区间覆盖的数量,依次输出。覆盖条件:[Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj

分析:对于每个区间,如果直接按照区间的左端点排序,这样就很好的解决了端点的覆盖问题。

///树状数组+贪心 先按左端点排 如果相等则按照右端点远的先排,注计算时相等的区间叠加计数计算。 这样从左到右贪过去,很好的解决了区间端点重复问题
#include<cstring>
#include<string>
#include<iostream>
#include<queue>
#include<cstdio>
#include<algorithm>
#include<map>
#include<cstdlib>
#include<cmath>
#include<vector>

using namespace std;

#define INF 0x3f3f3f3f

struct node
{
    int l,r;
    int ans;
} T[100005];

int c[100006];
int e[100006];
int maxn;

void init()
{
    maxn=100004;
    for(int i=0; i<=100004; i++)
    {
        e[i]=i;
        c[i]=0;
    }
}

bool cmp(int a,int b)
{
    if(T[a].l==T[b].l) return T[a].r>T[b].r;
    return T[a].l<T[b].l;
}

int lowbit(int x)
{
    return x&(-x);
}

void update(int x,int val)
{
    while(x<=maxn)
    {
        c[x]+=val;
        x+=lowbit(x);
    }
}

int query(int x)
{
    int sum=0;
    while(x>0)
    {
        sum+=c[x];
        x-=lowbit(x);
    }
    return sum;
}

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        init();
        for(int i=0; i<n; i++)
        {
            scanf("%d%d",&T[i].l,&T[i].r);
            T[i].ans=0;
            T[i].l+=1;
            T[i].r+=1;
        }

        sort(e,e+n,cmp);

        int l=T[0].l,r=T[0].r;
        int vis=1;
        for(int i=0; i<n; i++)
        {
            int v=e[i];
            int temp=min(query(T[v].l),query(T[v].r));

            if(T[v].r==r&&T[v].l==l)
                temp-=vis,vis++;
            else vis=1;
            if(temp>=0) T[v].ans=temp;

            update(T[v].l,1);
            update(T[v].r+1,-1);

            l=T[v].l;
            r=T[v].r;
        }

        for(int i=0; i<n; i++)
            printf("%d%c",T[i].ans,i==n-1?'\n':' ');
    }
    return 0;
}


你可能感兴趣的:(POJ 2481 Cows)