hdu 2492 Ping pong (树状数组)

Ping pong

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3964    Accepted Submission(s): 1467


Problem Description
N(3<=N<=20000) ping pong players live along a west-east street(consider the street as a line segment). 

Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must choose a referee among other ping pong players and hold the game in the referee's house. For some reason, the contestants can’t choose a referee whose skill rank is higher or lower than both of theirs.

The contestants have to walk to the referee’s house, and because they are lazy, they want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or any of the two contestants is different, we call two games different. Now is the problem: how many different games can be held in this ping pong street?
 

Input
The first line of the input contains an integer T(1<=T<=20), indicating the number of test cases, followed by T lines each of which describes a test case.


Every test case consists of N + 1 integers. The first integer is N, the number of players. Then N distinct integers a1, a2 … aN follow, indicating the skill rank of each player, in the order of west to east. (1 <= ai <= 100000, i = 1 … N).
 

Output
For each test case, output a single line contains an integer, the total number of different games.
 

Sample Input
   
   
   
   
1 3 1 2 3
 

Sample Output
   
   
   
   
1
 
理解错题了 委屈  the contestants can’t choose a referee whose skill rank is higher or lower than both of theirs,题中说不能选比他俩大的或比他俩小的当裁判,这么说rank相同就可以了,所以按rank排了个序,用一个树状数组和组合数可以搞定,但是一直wa,在网上搜题解才发现与我理解的不一样,只能一个比裁判rank大,一个比裁判rank小,这样用两个树状数组就可以了,一个统计左边比他大的和比他小的个数,一个统计右面,最后再枚举一下裁判就行了,就是左边比裁判大的个数*右边比裁判小的个数+左边比裁判小的个数*右边比裁判大的个数

代码:
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn=200000+100;
int a[maxn];
int n;
long long ans;
int b[maxn];
int max1[maxn];
int min1[maxn];
int max2[maxn];
int min2[maxn];
int low(int k)
{
    return k&(-k);
}
void update(int k,int v)
{
    while(k<maxn)
    {
        a[k]+=v;
        k+=low(k);
    }
}
long long getsum(int k)
{
    long long ans=0;
    while(k>0)
    {
        ans+=a[k];
        k-=low(k);
    }
    return ans;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&b[i]);
        }
        memset(a,0,sizeof(a));
        for(int i=1;i<=n;i++)
        {
            update(b[i],1);
            max1[i]=getsum(maxn-1)-getsum(b[i]);//左边比当前值大的
            min1[i]=getsum(b[i]-1);//左边比当前值小的
        }
        memset(a,0,sizeof(a));
        for(int i=n;i>=1;i--)
        {
            update(b[i],1);
            max2[i]=getsum(maxn-1)-getsum(b[i]);//右边比当前值大的
            min2[i]=getsum(b[i]-1);//右边比当前值小的
        }
        ans=0;
        for(int i=1;i<=n;i++)
        {
            ans+=max1[i]*min2[i];
            ans+=max2[i]*min1[i];
        }
        printf("%I64d\n",ans);
    }
    return 0;
}

你可能感兴趣的:(Algorithm)