poj 3268 Silver Cow Party

Silver Cow Party
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 16654   Accepted: 7604

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively:  NM, and  X 
Lines 2.. M+1: Line  i+1 describes road  i with three space-separated integers:  AiBi, and  Ti. The described road runs from farm  Ai to farm  Bi, requiring  Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

Source

USACO 2007 February Silver
题意:块田中都有一头牛去参加聚会,聚会被安排在X块田,一共有M条单行道(注意!!!)分别连着着两块田,

且通过路i需要花Ti(1≤Ti≤100)的时间。每头母牛必需参加宴会并且在宴会结束时回到自己的田地,但是每头牛都很懒而喜欢选择时间最少的一个方案。来时的路和去时的可能不一样。

找出来回路程最长的。输出来回最长的距离花费的时间

#include<stdio.h>
#include<string.h>
# define INF 0xfffffff
int map[1010][1010];
int dis[1010];
int used[1010],num[1010];
int n,m,x;
void dijs(int v)
{
	int i,j,k,min;
	for(i=1;i<=n;i++)//初始化 
	{
		dis[i]=INF;
		used[i]=0;
	}
	dis[v]=0;
	used[v]=1;
	for(i=1;i<=n;i++)
	{
		 min=INF;
		 k=v;
		for(j=1;j<=n;j++)
		{
			if(!used[j]&&min>dis[j])
			{
				k=j;
				min=dis[j];
			}
		}
		used[k]=1;
		for(j=1;j<=n;j++)
		{
			if(dis[j]>dis[k]+map[k][j])
			dis[j]=dis[k]+map[k][j];
		}
	}
 } 
 void tran()//转换矩阵 
 {
 	int temp,i,j;
 	for(i=1;i<=n;i++)
	 for(j=1;j<i;j++)
	 {
	 	temp=map[i][j];
	 	map[i][j]=map[j][i];
	 	map[j][i]=temp;
	 }
 }
 int main()
 {
 	int i,j,a,b,c;
  while(scanf("%d%d%d",&n,&m,&x)!=EOF)	
  {
  	for(i=1;i<=n;i++)
 	for(j=1;j<=n;j++)
 	map[i][j]=INF;
 	for(i=0;i<m;i++)
 	{
 		scanf("%d%d%d",&a,&b,&c);
	    map[a][b]=c; 
	 }
	 dijs(x);
	 for(i=1;i<=n;i++)
	 num[i]=dis[i];
	 tran();
	 dijs(x);
	 int max=0;
	 for(i=1;i<=n;i++)
	 if(dis[i]+num[i]>max)
	 max=dis[i]+num[i];
	 printf("%d\n",max);
  }
 	
	 return 0;
 }


你可能感兴趣的:(poj 3268 Silver Cow Party)