hdu 5204 Rikka with sequence(BestCoder Round #37)

Rikka with sequence

                                                       Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
                                                                                  Total Submission(s): 378    Accepted Submission(s): 75


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:


Yuta have a sequence. Because the sequence is very self-willed(RenXing), at first the sequence is empty. And then Yuta do n operations on this sequence, each operation is either of these two types:


1.Add a number w into each gap of the sequence. For example if w=3 and the sequence before is “2 4”, it will be changed to “3 2 3 4 3”.
**after the first operation of the first type, there is only one number in the sequence**


2.Query the kth small number in the subsequence [L,R]. For example if k=2, L=2, R=4 and the sequence is “3 2 3 4 2”, the answer will be 3.


Yuta wants Rikka to tell him the answer of each query.


It is too difficult for Rikka. Can you help her?
 

Input
The first line contains one number  n(n100000) . Each of the following  n  lines describes an operation: if it is “1 w” it will be the first type. Otherwise if it is “2 L R k”, it will be the second type.  (1w109,LR1018)
R will not be larger than the length of the sequence
 

Output
For each query operation, output one number – the answer.
 

Sample Input
   
   
   
   
6 1 3 1 1 2 2 3 2 1 2 2 3 5 2 2 1 4 4
 

Sample Output
   
   
   
   
3 2 3
 

官方题解:
这题看起来一副非常厉害的样子。。其实是大水题。 对于一个询问,考虑这个询问前第 i 次修改操作,那么这次修改操作出现在序列中第一个位置是 2i1 。然后在询问范围内最多只有 60 个数,暴力大法好就好了,时间复杂度 O(nlogR)  R 是询问的最大下标。
 
ps:自己模拟一下就会发现,对第i个要插入的数,在整个区间内插入的数的数量是2^(i-1)个,并且在[1,R]内也满足,后一个数插入的数的数量一定是前一个插入数的2倍,或2倍+1,知道这个后,[L,R]=[1,R]-[1,L-1],于是sum[i]+=v*(x+1)/2;在[1,R]中v为1,在[1,L-1]中v为-1,此时的i的顺序与插入顺序相反。
 
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=110000;
int a[maxn],b[maxn];
long long sum[maxn];
int len=69;
void digt(long long x,int v)
{
    int i=0;
    while(x)
    {
        sum[i]+=v*(x+1)/2;
        x=x/2;
        i++;
    }
}
bool cmp(int x,int y)
{
    return a[len-x]<a[len-y];
}
int main()
{
    int t,op;
    scanf("%d",&t);
    long long l,r,k,ans;
    while(t--)
    {
        scanf("%d",&op);
        if(op==1)
        {
            scanf("%d",&a[++len]);
        }
        else
        {
            scanf("%I64d%I64d%I64d",&l,&r,&k);
            for(int i=0;i<=100;i++)
            sum[i]=0;
            digt(r,1);
            digt(l-1,-1);
            for(int i=0;i<=69;i++)
            b[i]=i;
            sort(b,b+70,cmp);
            ans=0;
            for(int i=0;i<70;i++)
            {
               // cout<<i<<"    "<<sum[b[i]]<<endl;
                if(ans+sum[b[i]]>=k)
                {
                    printf("%d\n",a[len-b[i]]);
                    break;
                }
                else
                {
                    ans+=sum[b[i]];
                }
            }
        }
    }
    return 0;
}





你可能感兴趣的:(Algorithm,ACM,BestCoder)