HDOJ 1222 Wolf and Rabbit(判断互质,水)

Wolf and Rabbit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6688    Accepted Submission(s): 3328


Problem Description
There is a hill with n holes around. The holes are signed from 0 to n-1.

HDOJ 1222 Wolf and Rabbit(判断互质,水)_第1张图片

A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
 

Input
The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
 

Output
For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
 

Sample Input
   
   
   
   
2 1 2 2 2
 

Sample Output
   
   
   
   
NO YES
 

题意:有n个山洞围成环,编号从0~n-1。 羊躲在其中的一个山洞里。狼从0号山洞开始找羊,然后m号山洞,2*m号山洞,以此循环下去。 问羊是否存在可能让狼找不到?

题解: 这种题做过好几次了, 判断m和n是否互质啊。n和m的最大公约数为1则表示互质,狼可以找完所有的山洞。反之则不互质。

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

bool gcd(int n,int m)
{
	int i;
	while(m)
	{
		i=n%m;
		n=m;
		m=i;
	}
	if(n==1)
		return true;
	else
		return false;
}

int main()
{
	int t,n,m;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&m,&n);
		if(m>n)
		{
			int p=n;
			n=m;
			m=p;
		}
		if(gcd(n,m))
			printf("NO\n");
		else
			printf("YES\n");
	}
	return 0;
} 


你可能感兴趣的:(HDOJ 1222 Wolf and Rabbit(判断互质,水))