An Easy Task
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3795 Accepted Submission(s): 2177
Problem Description
Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?
Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.
Note: if year Y is a leap year, then the 1st leap year is year Y.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains two positive integers Y and N(1<=N<=10000).
Output
For each test case, you should output the Nth leap year from year Y.
Sample Input
3
2005 25
1855 12
2004 10000
Sample Output
2108
1904
43236
Hint
We call year Y a leap year only if (Y%4==0 && Y%100!=0) or Y%400==0.
//好了,我不得不承认,这题我卡了半天了,一直想不出来第三个数据怎么出的。
我发现我错在 闰年是 重点内容而我,则天真的以为每四年就是一闰了。
#include <stdio.h>
#include <iostream>
#include <string.h>
#include <queue>
#include <algorithm>
using namespace std;
int runjudge(int a)
{
if(a%400==0||(a%4==0&&a%100!=0))
return 1;
return 0;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int num,ans;
int n,i,m;
ans=0;
scanf("%d%d",&n,&m);
num=n;
for(i=n;;i++)
{
if(runjudge(i))
{
ans++;
num=i;
}
if(ans==m)
break;
}
printf("%d\n",num);
}
return 0;
}