POJ 2406 Power Strings

POJ 2406

G - Power Strings
Time Limit:3000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Submit

Status

Practice

POJ 2406
Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = “abc” and b = “def” then a*b = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.

给你一个字符串,求最小循环节循环了多少次。

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
#define maxs 2000005
using namespace std;
int nexts[maxs];
char s[maxs];
void get_nexts(char *s,int *n)
{
    int i=0,k=-1;
    n[0]=-1;
    int len=strlen(s);
    while(i<len)
    {
        if(k==-1||s[i]==s[k])
        {
            i++,k++,n[i]=k;
        }
        else
            k=n[k];
    }
}
int main()
{
    while(~scanf("%s",s))   //求最小循环节,之后求循环次数的问题!
    {
        if(s[0]=='.')
            break;
       // printf("string is %s\n",s);
        int len=strlen(s);
        get_nexts(s,nexts);
        int ans,min_repeat=len-nexts[len];
        //printf("nexts[len] is %d\n",nexts[len]);
        if(len%min_repeat!=0)
            ans=1;
        else ans=len/min_repeat;
        printf("%d\n",ans);
    }
    return 0;
}

你可能感兴趣的:(KMP)