Uva 10082 POJ2538 WERTU(简单字符操作)



WERTYU
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8971   Accepted: 4288

Description

Uva 10082 POJ2538 WERTU(简单字符操作)_第1张图片 
A common typing error is to place the hands on the keyboard one row to the right of the correct position. So "Q" is typed as "W" and "J" is typed as "K" and so on. You are to decode a message typed in this manner.

Input

Input consists of several lines of text. Each line may contain digits, spaces, upper case letters (except Q, A, Z), or punctuation shown above [except back-quote (`)]. Keys labelled with words [Tab, BackSp, Control, etc.] are not represented in the input.

Output

You are to replace each letter or punctuation symbol by the one immediately to its left on the QWERTY keyboard shown above. Spaces in the input should be echoed in the output. 

Sample Input

O S, GOMR YPFSU/

Sample Output

I AM FINE TODAY.

原题链接:https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=1023

POJ链接:http://poj.org/problem?id=2538

Virtual OJ链接:http://acm.hust.edu.cn/vjudge/problem/viewProblem.action?id=19338

水题,但是要注意输入不能用scanf(),因为输入中含有空格,用gets(),或者getchar()


AC代码:

#include <stdio.h>
char *s = "`1234567890-=QWERTYUIOP{}\\ASDFGHJKL:'ZXCVBNM,./";
int main()
{
    int i,c;
    while((c = getchar()) != EOF)
    {
        for (i = 1; s[i] && s[i]!=c; i++);
        if(s[i]) putchar(s[i-1]);
        else putchar(c);
    }
    return 0;
}

上面那个代码是<<算法竞赛入门经典>>上面的,下面那个代码是我的...

#include <stdio.h>
int main()
{
    char x[100]="`1234567890-=QWERTYUIOP[]\\ASDFGHJKL;'ZXCVBNM,./";
    int i,j;
    char a[1000];
    while(gets(a))
    {
        for (i=0;a[i]!='\0';i++)
        {
            if (a[i]==' ')
            {
                printf(" ");
                continue ;
            }
            for (j=0;x[j]!='\0';j++)
            {
                if (a[i]==x[j])
                {
                    printf("%c",x[j-1]);
                }
            }
        }
        printf("\n");
    }
    return 0;
}



你可能感兴趣的:(POJ2538,WERTU,Uva10082)