POJ1860 Currency Exchange

Currency Exchange
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 19419   Accepted: 6926

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES


=============华丽的分割线=============




题目大意:Nic有一点小钱,想搞投资赚点外快,有S种货币,他们之间有N家银行兑换,分别需要一点手续费,和兑换系数。

现在任你随便兑换,问Nick能不能赚钱(要换回原来的货币)。


思路,用Bellman-Ford算法的思路,判断有没有递增的环,复杂度o(VE);


#include <iostream>
#include <cmath>
#include <stdio.h>
#include <algorithm>
#include <ctime>
#include <vector>
#include <cstring>
#include <map>
#include <string>
#include <queue>
//#include <fstream>
using namespace std;
#define LL long long
#define ULL unsigned long long
//#define REP(i,n) for(int i=0;i<n;++i)
#define REP(i,a,b) for(int i=a;i<=b;++i)
#define INFLL (1LL)<<62
#define mset(a) memset(a,0,sizeof a)
#define FR(a) freopen(a,"r",stdin)
#define FW(a) freopen(a,"w",stdout)
#define PI 3.141592654
const LL MOD = 1000000007;
const int maxn=111;

struct E
{
	int a[2];
	double r[2],c[2];
	void scan()
	{
		scanf("%d%d%lf%lf%lf%lf",a,a+1,r,c,r+1,c+1);
	}
}edge[maxn];
double v[maxn];
int m,n,s;
double val;
bool bellman()
{
	mset(v);
	v[m]=val;
	REP(ii,1,s){
		double money=v[ii];
		bool flag = 0;
		REP(j,1,n){
			REP(k,0,1)
				if(v[edge[j].a[k^1]]<(v[edge[j].a[k]]-edge[j].c[k])*edge[j].r[k])
				{
					v[edge[j].a[k^1]]=(v[edge[j].a[k]]-edge[j].c[k])*edge[j].r[k];
					flag=1;
				}

		}
		if(!flag)	break;
	}
	REP(j,1,n){
		REP(k,0,1)
			if(v[edge[j].a[k^1]]<(v[edge[j].a[k]]-edge[j].c[k])*edge[j].r[k])
			{
				v[edge[j].a[k^1]]=(v[edge[j].a[k]]-edge[j].c[k])*edge[j].r[k];
				return true;
			}
	}
	return false;
}

int main()
{
	while (cin>>s>>n>>m>>val)
	{
		REP(ii,1,n)
			edge[ii].scan();
		if(bellman())	puts("YES");
		else			puts("NO");
	}
}


你可能感兴趣的:(POJ1860 Currency Exchange)