1.
因为思念新宿的”小姐姐”们,岛娘计划6月份再去一趟东京,不过这次看来她需要自掏腰包。经过了几天的夜战,岛娘终于在体力耗尽之前,用Python抓下了所有6月份,上海至东京的全部共 n 张机票。现在请你帮助债台高筑的岛娘筛选出符合时间区间要求的,最贵的机票。
输入
输入数据的第一行包含两个整数 n, m(1 ≤ n, m ≤ 105),分别表示机票的总数,和询问的总数。接下来的 n 行,每行两个整数 t, v (1 ≤ t, v ≤ 105),表示每张机票出发的时间和价格。 接下来的 m 行,每行两个整数 a, b (1 ≤ a ≤ b ≤ 105),表示每个询问所要求的时间区间。
输出
对于每组询问,输出一行表示最贵的价格。如果没有符合要求的机票,输出一行”None”。
样例输入7 6
1 1
2 1
4 3
4 4
4 5
6 9
7 9
1 7
1 2
6 7
3 3
4 4
5 5
样例输出9
1
9
None
5
None
这是一道简单的线段树的单点更新和查询的线段树题目,虽然WA了两发,看错了题意,还有一种情况没有考虑到。
下面是AC代码:
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
struct node
{
int left,right,val;
} c[2000005];
void build_tree(int l,int r,int root)
{
c[root].left=l;
c[root].right=r;
if(c[root].left==c[root].right)
{
c[root].val=0;
return ;
}
int mid=(c[root].left+c[root].right)/2;
build_tree(l,mid,root*2);
build_tree(mid+1,r,root*2+1);
c[root].val=max(c[root*2].val,c[root*2+1].val) ;
}
void search_tree(int l,int r,int root,int &maxn)
{
if(c[root].left==l&&c[root].right==r)
{
maxn=c[root].val;
return ;
}
int mid=(c[root].left+c[root].right)/2;
if(mid<l)
{
search_tree(l,r,root*2+1,maxn);
}
else if(mid>=r)
{
search_tree(l,r,root*2,maxn);
}
else
{
int maxn1;
int mid=(c[root].left+c[root].right)/2;
search_tree(l,mid,root*2,maxn1);
search_tree(mid+1,r,root*2+1,maxn);
maxn=max(maxn,maxn1);
}
}
void update_tree(int pos,int root,int x)
{
if(c[root].left==c[root].right&&c[root].right==pos)
{
if(c[root].val<=x)//坑点在这里
c[root].val=x;
return ;
}
int mid=(c[root].left+c[root].right)/2;
if(pos>mid)
update_tree(pos,root*2+1,x);
else
update_tree(pos,root*2,x);
c[root].val=max(c[root*2].val,c[root*2+1].val);
}
int main()
{
int n,m;
while(~scanf("%d%d",&n,&m))
{
memset(c,0,sizeof(c));
build_tree(1,400000,1);
for(int i=0; i<n; i++)
{
int a,b;
scanf("%d%d",&a,&b);
update_tree(a,1,b);
}
for(int i=0; i<m; i++)
{
int a,b,maxn;
scanf("%d%d",&a,&b);
if(a<b)
search_tree(a,b,1,maxn);
else
search_tree(b,a,1,maxn);
if(maxn!=0)
printf("%d\n",maxn);
else
{
printf("None\n");
}
}
}
return 0;
}
2.
描述
岩手县北上市的「北上市立公园展胜地」,是陆奥国三大樱花名所之一。每年的四月中旬到五月初,这里都会举办盛大的祭奠。除了可以在盛开的樱花步道上乘坐观光马车徐行、还有横跨北上川上的鲤鱼旗,河畔还有当地特有的为祭奠祖先而编创的北上鬼剑舞。
假设,我们用一个包含 ‘(‘, ‘)’的括号字符串来区别每面鲤鱼旗的方向。一段括号序列被称为合法的,当且仅当满足两个条件:一、对于整个序列,左括号数量等于右括号;二、对于任意前缀,左括号的数目都不小于右括号的数目。岛娘想知道,对于一串括号字符串,有多少子串是合法的,你能帮助她么。
输入
输入数据仅一行,包含一个长度为 n (1 ≤ n ≤ 106) 的括号字符串。
输出
输出一行,表示合法的括号子串的数目。
样例输入 (()())
样例输出 4
这是一道简单的DP题,但是不太好想。
下面是AC代码:
#include<cstdio>
#include<cstring>
#include<stack>
#include<algorithm>
using namespace std;
char str[1000005];
int dp[1000005];
int main()
{
scanf("%s",str+1);
int len=strlen(str+1);
long long sum=0;
stack<int>s;
for(int i=1;i<=len;i++)
{
if(str[i]=='(')
{
s.push(i);
}
else if(!s.empty())
{
int t=s.top();
s.pop();
dp[i]=dp[t-1]+1;
sum+=dp[i];
}
}
printf("%lld\n",sum);
return 0;
}