Hust oj 1753 Triangular numbers(三角数)

Triangular numbers
Time Limit: 1000 MS Memory Limit: 65536 K
Total Submit: 65(43 users) Total Accepted: 43(41 users) Rating: Special Judge: No
Description

A triangular number is the number of dots in an equilateral triangle uniformly filled with dots. For example, three dots can be arranged in a triangle; thus three is a triangular number. The n-th triangular number is the number of dots in a triangle with n dots on a side.

Your task is to find out if a given integer is a triangular number.

Input

There are multiple test cases, processing to the end of file.

For each case:

The first line contains the single number n (1 n 500) — the given integer.

Output

For each case:

If the given integer is a triangular number output YES, otherwise output NO.

Sample Input
1
2
3
Sample Output
YES
NO
YES
 
读完了题没看明白什么叫三角数,于是找了找资料,然后就感觉这题好傻。。。

 三角数即 『 1, 3, 6, 10, 15, 21, 28, 36, 45, 55, 66, 78, ......』

Hust oj 1753 Triangular numbers(三角数)_第1张图片

1 = 1

1 + 2 = 3

1 + 2 + 3 = 6

1 + 2 + 3 + 4 = 10

1 + 2 + 3 + 4 + 5 = 15

1 + 2 + 3 + 4 + 5 + ... ...

规律很明显,F[n]=(n^2+n)/2,上代码
 
#include<iostream>
using namespace std;

int main()
{
    int i;
    int n;
    int a[501];
    for(i=1;i<=500;i++)
    {
        a[i]=i*(i+1)/2;
    }
    while(cin>>n)
    {
        int flag=0;
        for(i=1;i<=500;i++)
        {
            if(a[i]==n)
             {
                 flag=1;
                 break;
             }
        }
        if(flag==0)
            cout<<"NO"<<endl;
        else
            cout<<"YES"<<endl;
    }
}



你可能感兴趣的:(规律)