poj1007

DNA Sorting
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 94326   Accepted: 37904

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted). 

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length. 

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

题意:逆序数越大越在后,相同的话,按照原来的顺序输出就好了

#include<stdio.h>


char str[100][100];//记录字符矩阵的
int sort[100];//记录逆序数的
int sort_index[100];//为所有逆序数排序的
int sort_index1[100];//同上


int main()
{
    int column,raw;
//-------------------输入-------------------------//
    scanf("%d %d",&column,&raw);
    getchar();
    for(int i=0;i<raw;i++){
        for(int j=0;j<column;j++)
            str[i][j]=getchar();
        getchar();
    }
//-------------------计算逆序数-------------------//


    for(int i=0;i<raw;i++){
        sort_index[i]=0;
        sort[i]=0;
    
        for(int j=0;j<column-1;j++)
            for(int k=j+1;k<column;k++)
                if(str[i][j]>str[i][k])
                    sort[i]++;
    }


//-----------按照逆序数大小进行排序-----------------//
    for(int i=0;i<raw-1;i++){
        for(int j=i+1;j<raw;j++){
            if(sort[i]>sort[j])
                sort_index[i]++;
            else
                sort_index[j]++;
        }
    }
//--------------按照逆序数排序-------------------//
    for(int i=0;i<raw;i++)
        sort_index1[sort_index[i]]=i;


//--------------------输出------------------------//
    for(int i=0;i<raw;i++){
        for(int j=0;j<column;j++)
            printf("%c",str[sort_index1[i]][j]);
        puts("");
    }
    return 0;
}



你可能感兴趣的:(poj1007)