HDU 5264 pog loves szh I

Problem Description
Pog has lots of strings. And he always mixes two equal-length strings. For example, there are two strings: "abcd" and "efgh". After mixing, a new string "aebfcgdh" is coming.

However, szh thinks it is boring, so he reverses the second string, like changing "efgh" to "hgfe". Then mix them as usual, resulting in "ahbgcfde".

Now, here comes a problem. Pog is given a string after mixing by szh, but he wants to find the original two strings. 

Hint : In this question, it needs a linefeed at the end of line at hack time.
 

Input
The first line has an integer,  T(1T100) , indicating the number of cases.

Then follows  T  lines. Every lines has a string S, whose length is even and not more than  100 , and only consists of lower-case characters('a'~'z').
 

Output
For each cases, please output two lines, indicating two original strings.
 

Sample Input
   
   
   
   
1 aabbca
 

Sample Output
   
   
   
   
abc aba For example, there are two strings: "abcd" and "efgh". After mixing, a new string "aebfcgdh" is coming.
 

#include<cstdio>
#include<cstring>
#include<vector>
#include<iostream>
#include<queue>
#include<algorithm>
#include<cmath>
#include<string>
using namespace std;
const int maxn = 1005;
int T, n, m; 
string a, b, s;

int main()
{
    scanf("%d", &T);
    while (T--)
    {
        cin >> s;
        b = a = "";
        for (int i = 0; s[i]; i++)
        {
            if (i & 1) b = s[i] + b;
            else a = a + s[i];
        }
        cout << a << endl;
        cout << b << endl;
    }
}


你可能感兴趣的:(HDU 5264 pog loves szh I)