poj 2782 Bin Packing

Description

A set of n 1-dimensional items have to be packed in identical bins. All bins have exactly the same length l and each item i has length li<=l . We look for a minimal number of bins q such that 
  • each bin contains at most 2 items, 
  • each item is packed in one of the q bins, 
  • the sum of the lengths of the items packed in a bin does not exceed l .

You are requested, given the integer values n , l , l1 , ..., ln , to compute the optimal number of bins q . 

Input

The first line of the input contains the number of items n (1<=n<=10 5) . The second line contains one integer that corresponds to the bin length l<=10000 . We then have n lines containing one integer value that represents the length of the items.

Output

Your program has to write the minimal number of bins required to pack all items.

Sample Input

10
80
70
15
30
35
10
80
20
35
10
30

Sample Output

6

Hint

The sample instance and an optimal solution is shown in the figure below. Items are numbered from 1 to 10 according to the input order. 

poj 2782 Bin Packing_第1张图片



这道题要注意一个误区:最大的要和尽可能大的配对;

实际上并不用,最大和最小配对就是最优了;

这样程序就很简单了;


#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int main()
{
    int n,l;
    scanf("%d",&n);
    scanf("%d",&l);
    int s[100005];
    for(int i=0;i<n;++i)
    {
        scanf("%d",&s[i]);
    }
    sort(s,s+n);
    int ans=0;
    for(int i=n-1,j=0;i>=j;)
    {
        if(s[i]+s[j]<=l)
        {
            --i;
            ++j;
            ++ans;
        }
        else{
            --i;
            ++ans;
        }
    }
    cout<<ans<<endl;
    return 0;
}



你可能感兴趣的:(poj)