1012 of greedy strategy

Problem Description
Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be only of theoretical interest. 
This problem involves the efficient computation of integer roots of numbers. 
Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem, given such integers n and p, p will always be of the form k to the n th. power, for an integer k (this integer is what your program must find).
 

Input
The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200, 1<=p<10<sup>101</sup> and there exists an integer k, 1<=k<=10<sup>9</sup> such that k<sup>n</sup> = p.
 

Output
For each integer pair n and p the value k should be printed, i.e., the number k such that k n =p.
 

Sample Input
   
   
   
   
2 16 3 27 7 4357186184021382204544
 

Sample Output
   
   
   
   
4 3 1234
 题目要求:求某数的某次跟。
思路:直接用数学函数计算。
细节:先用double类然后储存为int,还有就是四舍五入。
#include<cstdio>
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
    double r, m;
    int e;
    while (cin>>r>>m)
    {
        e= pow(m, 1.0 / r)+0.5;

        printf("%d\n", e);
    }
}


你可能感兴趣的:(1012 of greedy strategy)