POJ 1012 jeseph

Joseph
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 48575   Accepted: 18335

Description

The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved. 

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy. 

Input

The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

Output

The output file will consist of separate lines containing m corresponding to k in the input file.

Sample Input

3
4
0

Sample Output

5
30


#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#define N 500
using namespace std;

int jeseph[N];
int p[N];
int k;

int main()
{

    while(scanf("%d",&k),k)
    {
        if(jeseph[k])//多组数据,防止TLE
        {
            printf("%d\n",jeseph[k]);
            continue;
        }

        int n=2*k;
        int m=1;

        p[0]=0;

        for(int i=1;i<=k;i++)
        {
            p[i]=(p[i-1]+m-1)%(n-i+1);
            if(p[i]<k)//让编号从0~n-1
            {
                i=0;
                m++;
            }
        }

        jeseph[k]=m;
        cout<<m<<endl;
    }
    return 0;
}






你可能感兴趣的:(POJ 1012 jeseph)