ZOJ - 3880 Demacia of the Ancients (水)

ZOJ - 3880
Demacia of the Ancients
Time Limit:                                                        2000MS                          Memory Limit: 65536KB   64bit IO Format:                            %lld & %llu                       

SubmitStatus

Description

There is a popular multiplayer online battle arena game called Demacia of the Ancients. There are lots of professional teams playing this game. A team will be approved as Level K if there are exact K team members whose match making ranking (MMR) is strictly greater than 6000.

You are given a list of teams. Please calculate the level of each team.

<h4< body="">

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 10) indicating the number of team members.

The second line contains N integers representing the MMR of each team member. All MMRs are non-negative integers less than or equal to 9999.

<h4< body="">

Output

For each test case, output the level of the given team.

<h4< body="">

Sample Input

3
5
7986 6984 6645 6200 6150
5
7401 7377 6900 6000 4300
3
800 600 200
<h4< body="">

Sample Output

5
3
0

Hint

Source

The 12th Zhejiang Provincial Collegiate Programming Contest
题意:
给你n个数,问你这n个数中有几个数大于6000.
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstring>
#include<algorithm>
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n;
		int ans=0;
		int x;
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			scanf("%d",&x);
			if(x>6000)
			ans++;
		}
		printf("%d\n",ans);
	}
	return 0;
}

你可能感兴趣的:(ZOJ - 3880 Demacia of the Ancients (水))