HDU 1060 Leftmost Digit(大数问题)

Description
Given a positive integer N, you should output the leftmost digit of N^N.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output
For each test case, you should output the leftmost digit of N^N.

Sample Input
2
3
4

Sample Output
2
2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
题目大意:输入N,求N^N的最高位数字。1<=N<=1,000,000,000

估计大家看到N的范围就没想法了

首先用科学计数法来表示 N^N = a*10^x;

比如N = 3; 3^3 = 2.7 * 10^1;

我们要求的最右边的数字就是(int)a,即a的整数部分;

OK, 然后两边同时取以10为底的对数 lg(N^N) = lg(a*10^x) ;

化简 N*lg(N) = lg(a) + x;

继续化 N*lg(N) - x = lg(a)

a = 10^(N*lg(N) - x);

现在就只有x是未知的了,如果能用n来表示x的话,这题就解出来了。

又因为,x是N^N的位数。比如 N^N = 1200 ==> x = 3;

实际上就是 x 就是lg(N^N) 向下取整数,表示为[lg(N^N)]

a = 10^(N*lg(N) - [lg(N^N)]);

然后(int)a 就是答案了。

#include<iostream>
#include<cmath>
#include<cstdio>
using namespace std;
int main()
{
    int t;
    __int64 n,a;
    long double t1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%I64d",&n);
        t1=n*log10(n+0.0);
        t1-=(__int64)t1;
        a=pow((long double)10,t1);
        printf("%I64d\n",a);
    }
}


你可能感兴趣的:(ACM,大数,HDU解题报告)