A Knight's Journey
Time Limit: 1000MS |
|
Memory Limit: 65536K |
Total Submissions: 38821 |
|
Accepted: 13158 |
Description
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
Sample Input 3
1 1
2 3
4 3 Sample Output Scenario #1:
A1
Scenario #2:
impossible
Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
Source
TUD Programming Contest 2005, Darmstadt, Germany
|
题目描述:
用大写字母表示行,数字表示列,判断马是否可以不重复的走完整个地图,输出字典序最小的序列,如果不可能输出impossible。
深度优先搜索考虑到字典序最小,所以直接从A1开始搜,但要按(-1,-2) (1,-2) (-2,-1) (2,-1) (-2,1) (2,1) (-1,2) (1,2)顺序方向进行搜索,才能保证字典序搜到的是最小的。
代码:
#include<stdio.h>
#include<string.h>
int road[80][2],vis[80][80]; //vis数组进行标记是否已经访问过
int n;
int p,q;
int dx[8] = {-1,1,-2,2,-2,2,-1,1},dy[8] = {-2,-2,-1,-1,1,1,2,2};
int flag;
void dfs(int r,int c,int step) //当前 行,列,步数
{
road[step][0] = r;
road[step][1] = c;
if(step == p * q) //如果能走完,步数应该为p*q
{
flag = 1;
return ;
}
for(int i = 0;i < 8;i++)
{
int nx = r + dx[i],ny = c + dy[i];
if(nx >= 1 && nx <= p && ny >= 1 && ny <= q && vis[nx][ny] == 0 && !flag) //判断是否将要走的位置是否合法
{
vis[nx][ny] = 1;
dfs(nx,ny,step + 1);
vis[nx][ny] = 0;
}
}
}
int main()
{
scanf("%d",&n);
int k = 1;
while(n--)
{
flag = 0;
scanf("%d%d",&p,&q);
memset(vis,0,sizeof(vis));
vis[1][1] = 1;
dfs(1,1,1);
printf("Scenario #%d:\n",k++);
if(flag)
for(int i = 1;i <= p * q;i++)
{
printf("%c%d",road[i][1] + 'A' - 1,road[i][0]); //进行一下转换
}
else
printf("impossible");
printf("\n");
if(n != 0)
printf("\n");
}
return 0;
}