HDU 1004 Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 74708    Accepted Submission(s): 27975


Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

   
   
   
   
5 green red blue red red 3 pink orange pink 0

Sample Output

   
   
   
   
red pink
//题意:就是看一下哪一个颜色的频率最高
//结题报告:签到题,每输入一个字符串,如果该字符串在当前的颜色中有,那么这个颜色的数量就+1,如果没有那么
//创建这个颜色
#include<iostream>
#include<cstring>
#include<string.h>
using namespace std;
int const N = 1000;
char color[N][15];
//搜索该字符串是否存在于当前空间
int search(char a[],int total)//total是当前空间中字符串总数
{
    for(int i = 0;i < total;i ++)
    {
        if(strcmp(a,color[i]) == 0)
            return i+1;
    }
    return 0;
}
int main()
{
    char a[16];
    int T,n,total = 0;
    int result[N+1] = {0};
    int k;
 //   cin>>T;//t组测试数据
    while(cin>>n&&n)//N组字符串
    {
        total = 0; //color清零
        memset(result,0,sizeof(int)*1001);
        for(int i = 0;i < n;i++)
        {
            cin>>a;
            if(k = search(a,total))
                result[k] ++;
            else
                strcpy(color[total],a),result[total+1]++,total++;
        }
        int max = 1;
        for(int i = 1;i <= total;i++)
        {
            if(result[i] > result[max])
                max = i;
        }
        cout<<color[max-1]<<endl;
      //  for(int i = 1;i <= total;i++)
        //    cout<<color[i-1]<<' '<<result[i]<<' ';

    }

}

你可能感兴趣的:(C++,ACM,hdoj,签到题)