POJ 2425.A Chess Game【博弈论(SG函数)】【4月6】

A Chess Game
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 3645   Accepted: 1489

Description

Let's design a new chess game. There are N positions to hold M chesses in this game. Multiple chesses can be located in the same position. The positions are constituted as a topological graph, i.e. there are directed edges connecting some positions, and no cycle exists. Two players you and I move chesses alternately. In each turn the player should move only one chess from the current position to one of its out-positions along an edge. The game does not end, until one of the players cannot move chess any more. If you cannot move any chess in your turn, you lose. Otherwise, if the misfortune falls on me... I will disturb the chesses and play it again. 

Do you want to challenge me? Just write your program to show your qualification!

Input

Input contains multiple test cases. Each test case starts with a number N (1 <= N <= 1000) in one line. Then the following N lines describe the out-positions of each position. Each line starts with an integer Xi that is the number of out-positions for the position i. Then Xi integers following specify the out-positions. Positions are indexed from 0 to N-1. Then multiple queries follow. Each query occupies only one line. The line starts with a number M (1 <= M <= 10), and then come M integers, which are the initial positions of chesses. A line with number 0 ends the test case.

Output

There is one line for each query, which contains a string "WIN" or "LOSE". "WIN" means that the player taking the first turn can win the game according to a clever strategy; otherwise "LOSE" should be printed.

Sample Input

4
2 1 2
0
1 3
0
1 0
2 0 2
0

4
1 1
1 2
0
0
2 0 1
2 1 1
3 0 1 3
0

Sample Output

WIN
WIN
WIN
LOSE
WIN

题意:

给一个拓扑图,在一些点上有棋子,两个玩家每次轮流将一颗棋子沿有向边移动一次,无法移动则失败。

理解nim和状态的SG函数就ok。详细看代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
using namespace std;
int N, M, Xi, xi, m, ans;
int sg[1025], show[1025];
vector <int> son[1025];
int DFS(int rt)
{
    if(sg[rt] != -1) return sg[rt];
    int vis[1025];
    memset(vis, 0, sizeof(vis));
    vector <int>::iterator it = son[rt].begin();
    for(;it != son[rt].end(); ++it)//所有后继
    {
        vis[DFS(*it)] = 1;
    }
    for(int i = 0;; ++i)
    {
        if(vis[i] == 0)
        {
            sg[rt] = i;
            return i;
        }
    }
}
int main()
{
    while(scanf("%d", &N) != EOF)
    {
        memset(sg, -1, sizeof(sg));
        memset(show, 0, sizeof(show));
        for(int i = 0;i < N; ++i) son[i].clear();
        for(int i = 0;i < N; ++i)
        {
            scanf("%d", &Xi);
            while(Xi--)
            {
                scanf("%d", &xi);
                show[xi] = 1;
                son[i].push_back(xi);//保存后继节点
            }
        }
        for(int i = 0;i < N; ++i)
        {
            if(show[i] == 0) DFS(i);//当前为根节点,需要递归遍历求sg值
        }
        while(scanf("%d", &M) && M)
        {
            ans = 0;
            while(M--)
            {
                scanf("%d", &m);
                ans ^= sg[m];
            }
            if(ans == 0) cout <<"LOSE"<<endl;
            else cout <<"WIN"<<endl;
        }
    }
    return 0;
}


你可能感兴趣的:(C++,ACM,poj,博弈论)