Work
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1201 Accepted Submission(s): 734
Problem Description
It’s an interesting experience to move from ICPC to work, end my college life and start a brand new journey in company.
As is known to all, every stuff in a company has a title, everyone except the boss has a direct leader, and all the relationship forms a tree. If A’s title is higher than B(A is the direct or indirect leader of B), we call it A manages B.
Now, give you the relation of a company, can you calculate how many people manage k people.
Input
There are multiple test cases.
Each test case begins with two integers n and k, n indicates the number of stuff of the company.
Each of the following n-1 lines has two integers A and B, means A is the direct leader of B.
1 <= n <= 100 , 0 <= k < n
1 <= A, B <= n
Output
For each test case, output the answer as described above.
Sample Input
7 2
1 2
1 3
2 4
2 5
3 6
3 7
Sample Output
题目大意:有n个人,各自管理不同的人,问有多少人管理k个人。
思路:先记录每个人的直接上级,然后模拟寻根路径压缩的过程进行计数求和。
ac代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#define MAXN 2555
#define mod 1000000007
#define INF 0xfffffff
#define MIN(a,b) a>b?b:a
using namespace std;
int sum[MAXN];
int pri[MAXN];
int find(int x)
{
int r=x;
while(r!=pri[r])
r=pri[r];
int i=x,j;
while(i!=r)
{
j=pri[i];
sum[j]++;//并没有压缩路径,只是把那条路径上的结点的sum值全都加1
i=j;
}
return r;
}
int main()
{
int n,i,k,a,b;
while(scanf("%d%d",&n,&k)!=EOF)
{
for(i=1;i<=n;i++)
pri[i]=i;
memset(sum,0,sizeof(sum));
for(i=1;i<n;i++)
{
scanf("%d%d",&a,&b);
if(a!=b)//不用寻根,直接连
pri[b]=a;
}
for(i=1;i<=n;i++)
find(i);
int ans=0;
for(i=1;i<=n;i++)
{
if(sum[i]==k)
ans++;
}
printf("%d\n",ans);
}
return 0;
}