HDU 1358 (KMP)

Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5859    Accepted Submission(s): 2844


Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 

Sample Input
   
   
   
   
3 aaa 12 aabaabaabaab 0
 

Sample Output
   
   
   
   
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4
 


题意:求出所有前缀串中最小循环节长度小于自身的前缀,同时输出最小循环节

循环次数。

根据next数组,因为i-next[i]表示prefix[0...i-1]的最小循环节长度,所以直接遍历

判断即可。

#include <cstring>
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <vector>
#include <cmath>
using namespace std;
#define maxn 1111111

char T[maxn];
int n;
#define next Next
int next[maxn];

void get_next (char *p) {  
    int m = strlen (p);
    int t;  
    t = next[0] = -1;  
    int j = 0;  
    while (j < m) {  
        if (t < 0 || p[j] == p[t]) {//匹配  
            j++, t++;  
            next[j] = t;
        }  
        else //失配  
            t = next[t];  
    } 
}  

int main () {
    int kase = 0;
    while (scanf ("%d", &n) == 1 && n) {
        scanf ("%s", T);
        get_next (T); 
        printf ("Test case #%d\n", ++kase);
        for (int i = 1; i <= n; i++) {
            int j = next[i];
            int len = i-j;
            if (i%len == 0 && i/len > 1) {
                printf ("%d %d\n", i, i/len);
            }
        }
        printf ("\n");
    }
    return 0;
}


你可能感兴趣的:(HDU 1358 (KMP))