HDU 1019Least Common Multiple(欧几里得算法)

Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 … nm where m is the number of integers in the set and n1 … nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1

Sample Output
105
10296

本题的大致题意:就是给出一堆数,让你求出他们的最小公倍数。
要注意的点注释在了代码中。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;

int a[100005];
int gcd(int m,int n)
{
    int k,p,t;
    if(m<n) t=m;
    else t=n;
    for(k=t; ; k--)
        if(m%k==0&&n%k==0) break;
    return k;
}
int main()
{
    int n,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
        }
        int xx=a[0];
        for(int i=1; i<n; i++)
        {
            xx=xx/(gcd(xx,a[i]))*a[i];//一定要先除后乘,不然会有数据溢出的问题
        }
        printf("%d\n",xx);
    }
    return 0;
}

你可能感兴趣的:(HDU)