E - Lowest Common Multiple Plus

E - Lowest Common Multiple Plus
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u

Submit

Status

Practice

HDU 2028

Description

求n个数的最小公倍数。

Input

输入包含多个测试实例,每个测试实例的开始是一个正整数n,然后是n个正整数。

Output

为每组测试数据输出它们的最小公倍数,每个测试实例的输出占一行。你可以假设最后的输出是一个32位的整数。

Sample Input

2 4 6
3 2 5 7

Sample Output

12
70

我的:这个题比较坑,就是n*m/gcd;;
于n*m会大::定义的int,解决的办法是把数定义成long long,或者把表达式改成n/gcd*m;接下来是代码:#include<iostream>
using namespace std;
int n;
int gcd(int x,int y)
{
if(x%y==0)return y;
gcd(y,x%y);
}
long long a[1000+5];
int main()
{
while(cin>>n)
{
for(int i=0;i<n;i++)
cin>>a[i];
int k=a[0];
for(int i=1;i<n;i++)
{
k=k/gcd(k,a[i])*a[i];
}
cout<<k<<endl;
}
return 0;
}

你可能感兴趣的:(E - Lowest Common Multiple Plus)