杭电find the night

find the night

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 9729    Accepted Submission(s): 2830

Problem Description
假设: S1 = 1
S2 = 12
S3 = 123
S4 = 1234 .........
S9 = 123456789
S10 = 1234567891
S11 = 12345678912 ............
S18 = 123456789123456789 .................. 现在我们把所有的串连接起来
S = 1121231234.......123456789123456789112345678912......... 那么你能告诉我在S串中的第N个数字是多少吗?
 
Input
输入首先是一个数字K,代表有K次询问。 接下来的K行每行有一个整数N(1 <= N < 2^31)。
 
Output
对于每个N,输出S中第N个对应的数字.
 
Sample Input
6 1 2 3 4 5 10
 
Sample Output
1 1 2 1 2 4
 
 
#include <iostream>
using namespace std;
int main()
{
    int a;
    int t,n;
  cin>>t;
    while(t--)
    {
        cin>>a;
        n=1;
//实现n-s1-s2-s3-s4.............
         while(a>n)
        {
              a-=n;
              n++;
        }
        a%=9;if(a==0)    a=9;
       cout<<a<<endl;
    }
    return 0;
}

你可能感兴趣的:(杭电find the night)