Machine Schedule
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7113 Accepted Submission(s): 3564
Problem Description
As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.
There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.
For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.
Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines.
Input
The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.
The input will be terminated by a line containing a single zero.
Output
The output should be one integer per line, which means the minimal times of restarting machine.
Sample Input
5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0
Sample Output
Source
Asia 2002, Beijing (Mainland China)
这道题目是第二次做了,还是没有想出来,太弱了
首先,我们可以把可以在机器A_0,B_0上的任务自动完成,因为一次也不需要重启,便可以把这些任务完成,
其次是在每项任务完成的模式A,B之间建边,要求所有任务都完成的话,就是要求这些边都被取到,这样便是最小点覆盖题了
#include<bits/stdc++.h>
const int MAXN=2010;
const int MAXM=4000010;
struct Edge{
int to,next;
}edge[MAXM];
int tot;
bool used[MAXN];
int linker[MAXN];
int head[MAXN];
void init(){
tot=0;
memset(head,-1,sizeof(head));
}
void addedge(int u,int v){
edge[tot].to=v;
edge[tot].next=head[u];
head[u]=tot++;
}
bool dfs(int u){
for(int i=head[u];i!=-1;i=edge[i].next){
int v=edge[i].to;
if(!used[v]){
used[v]=true;
if(linker[v]==-1||dfs(linker[v])){
linker[v]=u;
return true;
}
}
}
return false;
}
int hungary(int n){
memset(linker,-1,sizeof(linker));
int ret=0;
for(int u=0;u<n;u++){
memset(used,false,sizeof(used));
if(dfs(u))
ret++;
}
return ret;
}
int main(){
int k,n,m;
int u,v;
while(scanf("%d",&n)!=EOF){
if(n==0)
break;
scanf("%d%d",&m,&k);
init();
int p;
for(int i=0;i<k;i++){
scanf("%d%d%d",&p,&u,&v);
if(u>0&&v>0)
addedge(u,v+n);
}
printf("%d\n",hungary(n));
}
return 0;
}