Co-prime
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2616 Accepted Submission(s): 1001
Problem Description
Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.
Input
The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 10
15) and (1 <=N <= 10
9).
Output
For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.
Sample Input
Sample Output
Case #1: 5
Case #2: 10
Hint
In the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.
Source
The Third Lebanese Collegiate Programming Contest
/*题意:[l,r]之间有多少个数与n互质,
利用容斥定理,[1,r]之间与n互质的数减去[1,l-1]之间与n互质的数
*/
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <cmath>
#include <ctime>
#include <vector>
#include <cstdio>
#include <cctype>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
using namespace std;
#define INF 0x3f3f3f3f
#define inf -0x3f3f3f3f
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define mem0(a) memset(a,0,sizeof(a))
#define mem1(a) memset(a,-1,sizeof(a))
#define mem(a, b) memset(a, b, sizeof(a))
typedef long long ll;
int n,m;
vector<int>p;
int main(){
int t;
scanf("%d",&t);
__int64 l,r;
int n;
for(int case1=1;case1<=t;case1++){
scanf("%I64d%I64d%d",&l,&r,&n);
l--;
p.clear();
for(int i=2;i*i<=n;i++){
if(n%i==0){
p.push_back(i);
while(n%i==0)
n/=i;
}
}
if(n>1)
p.push_back(n);
__int64 sum1=0,sum2=0;
for(int msk=1;msk<(1<<p.size());msk++){
int bits=0,mult=1;
for(int i=0;i<p.size();i++){
if(msk&(1<<i)){
mult*=p[i];
bits++;
}
}
__int64 r1=r/mult;
__int64 r2=l/mult;
if(bits&1){
sum1+=r1;
sum2+=r2;
}
else{
sum1-=r1;
sum2-=r2;
}
}
printf("Case #%d: %I64d\n",case1,r-sum1-l+sum2);
}
return 0;
}