HDU - 1060 Leftmost Digit (数学取对数)规律

HDU - 1060
Leftmost Digit
Time Limit:                                                        1000MS                          Memory Limit: 32768KB   64bit IO Format:                            %I64d & %I64u                       

SubmitStatus

Description

Given a positive integer N, you should output the leftmost digit of N^N.       
               

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.       
Each test case contains a single positive integer N(1<=N<=1,000,000,000).       
               

Output

For each test case, you should output the leftmost digit of N^N.       
               

Sample Input

     
     
     
     
2 3 4
               

Sample Output

     
     
     
     
2 2

Hint

 In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2. 
         
               

Source

//题意:

求n^n所得的数的最左边的以为的数是什么?

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<iostream>
using namespace std;
int main()
{
	int t,n;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		double m=n*log10(n);
		double mi=m-floor(m);
		printf("%d\n",(int)pow(10,mi));
	}
	return 0;
}


 

你可能感兴趣的:(HDU - 1060 Leftmost Digit (数学取对数)规律)